Talk:Bootable USB Key

From Knoppix Documentation Wiki
Jump to: navigation, search

lilino Hi ! I tried to follow your instructions for booting from a Kingston Datatraveler 2GB U3 . I used the "more than 1GB tip" but when i try to boot the led light is on but nothing happens. should i use different number of sectors and cylinders ? Is there a way to find the correct values ?

Bootable USB Key

I have an 8GB JetFlash from Transcend. I installed Knoppix 5.0.1 as described. I followed the recommendation for large drives when using the mkdiskimage command formatting to FAT32. This worked great for me. It boots on my Compaq Presario Laptop when selecting usb hard drive for startup drive in the bios. There is no choice for usb flash. So far I haven't been able to get the optional suggestion to work.... It read... On line 2, add a few more options to the end of the line. noswap noeject noprompt dma home=scan... I'm very new at using the terminal and I'm not sure where this command was supposed to go. I am surprised how well this procedure worked for me considering my lack of experience. The live flash drive operates the computer with great speed compared to a live cd. It felt as though I was running from the hard drive.

(Answers to questions above)

U3 = U3 is evil! Avoid U3. This can cause big problems when trying to boot up. U3 does something very nonstandard: in addition to being a USB key, it fakes out an additional "CD-ROM drive" inside the USB key, that holds the U3 software. This can confuse a BIOS when booting. I recommend deleting U3 if possible, or choosing another USB key that does not have U3. I personally have had at least one USB key ruined by U3.

Number of cylinders/heads/sectors = The mkdiskimage command will calculate the number of cylinders for you, when it is set to 0, so don't worry about that. See the bottom of the page for alternate mkdiskimage command lines you can try, for large USB keys. I recommend either "0 64 32" (64 heads and 32 sectors) for 1GB keys. For keys larger than 1GB, you might want to try these: "0 128 32", "0 256 32", "0 256 63", "0 255 32", "0 255 63". Unfortunately I can't recommend a specific one because it's really a crapshoot with the BIOS: sometimes it works, sometimes it doesn't, and it is different on different computers!

8GB USB keys = Good, I'm glad the alternate mkdiskimage command worked for you. I do not have access to such large keys to try myself.

The options to the end of the line = By this, I meant to use a text editor and edit the file with it. You don't actually type the options directly at the terminal. In Knoppix, click on the "K" menu, then choose "Editors" from the big list, and choose your favorite text editor. I recommend "NEdit", as it is easy to use and doesn't add any formatting to the file. It is essential that you leave the file as plain text, without forwarding, so be sure to use a simple editor and not a full-featured word processor (this will ruin the file). The "NEdit" text editor should be safe to use. Save the file and exit the text editor when done.

--Krellan 09:04, 28 Dec 2006 (GMT)

I have the same problem as above. I followed the directions on the main site exactly for useing knoppix on my sandisk 2gb (cruzer) stick and everything works fine. The stick will boot the non-moded mod just great. The problem comes when I attempt to modify the knoppix boot menu using the "optional" steps. I do the do the "Make usb writeable" step everything appears to work. It also appears to save the changes to the /media/sdb4/syslinux.cfg file (eg the adding of noswap, noeject, noprompt and dma to the second line). However, once I reboot somthing strange happens. Apperntly the device can no longer be detected as a bootable device, and boots up into windows instead. Not only that but windows cant even read or detect it any longer. To rectify this, I must start over and reformat the entire stick in knoppix again (using mkdiskimage 0 64 62 , btw). I've used the tool sandisk provide to remove U3 and the disk has been formated many times over, so that shouldnt be a problem. I am also using vi to edit the config file so that shouldnt do anything...I think the problem is deeper, like perhaps the way you are having people mount the usb key so it can be written to? I didnt see that the CD rom was mounted at all when I booted into knoppix from the seemed to recognize it was booting from the stick.I dont know. Anways,mabey I am just screwing up the config file as well. If you could perhaps post what your looks like, it might be helpfull.

So any suggestions?

--kryptofox 02:01, 25 Jan 2007 (PST)

That's a weird one. Maybe there is something wrong with making the "CD" writeable inside of Knoppix. I don't think so, though, and I've never had a problem as bad as that, where it completely fails to boot up afterwards.

Make sure you can boot up repeatedly, 2 or 3 times in a row. Some BIOS's are weird about only letting you boot into USB once, from a cold start. If you do a warm boot, they won't see the USB stick at all. Mine is that way, and it's a pain. I have to turn the computer completely off and on. So, it might not be the fault of Knoppix at all, if you can't boot into Knoppix more than once.

Also, please post questions like this into the main forums here:

That way, everybody will be able to see them, and hopefully respond sooner. Not many people check this "Talk:" page here, unfortunately. This isn't Wikipedia :)

--Krellan 18:43, 26 Oct 2007 (UTC)


I am not someone from this project, but as I was passing by, I have just undone some vandalism here. And looking this page history by doing so, I could notice this is far from being the first time, even with your captcha system. Shouldn't you consider to limit edition of this page? (like in Wikipedia, to people registered for at least some days and with other contributions for instance?) Bye and good luck.